All Deployments: Some users seeing "Invalid txid" error in Duo Prompt during authentication
Incident Report for Duo
Resolved
After several days of monitoring, we have confirmed this issue has been fully resolved on all customer deployments.

This issue was due to a bug triggered by a rare edge case when a user reached the Duo Prompt with both a U2F security key enrolled and automatic Duo Push behavior enabled. This bug has been remediated and automated testing has been implemented to detect potential similar issues moving forward.
Posted Dec 21, 2020 - 11:29 EST
Monitoring
Duo’s Engineering Team has successfully deployed a fix to all customers for the “Invalid txid” error some users saw in the Duo Prompt.

We will continue to monitor the situation to ensure the solution is working as intended.
Posted Dec 18, 2020 - 17:02 EST
Update
We have developed a fix for the issue where some users are being presented with "Invalid txid" error messages in the Duo Prompt during authentication. We are thoroughly testing before deploying it to customers to ensure no other impacts are observed.

Please continue to use the workaround of canceling the automatic push and requesting a new push authentication manually to authenticate successfully.
Posted Dec 17, 2020 - 18:02 EST
Identified
Duo has identified the cause of the ongoing issue where some users are being presented with "Invalid txid" error messages in the Duo Prompt during authentication and we are working on a solution.
A workaround is available: Users who are shown this error message can complete authentication by canceling an automatic push and requesting a new push authentication manually.
Posted Dec 16, 2020 - 14:15 EST
Investigating
We are currently investigating an issue where some users are being presented with "Invalid txid" error messages in the Duo Prompt during authentication.

Duo's Core Authentication service isn't down, but users may need to work around this error by canceling an automatic push and re-triggering a new push authentication manually.
Posted Dec 16, 2020 - 10:40 EST
This incident affected: DUO45 (Core Authentication Service), DUO9 (Core Authentication Service), DUO49 (Core Authentication Service), DUO51 (Core Authentication Service), DUO58 (Core Authentication Service), DUO63 (Core Authentication Service), DUO19 (Core Authentication Service), DUO10 (Core Authentication Service), DUO5 (Core Authentication Service), DUO1 (Core Authentication Service), DUO36 (Core Authentication Service), DUO44 (Core Authentication Service), DUO60 (Core Authentication Service), DUO15 (Core Authentication Service), DUO18 (Core Authentication Service), DUO66 (Core Authentication Service), DUO41 (Core Authentication Service), DUO43 (Core Authentication Service), DUO7 (Core Authentication Service), DUO23 (Core Authentication Service), DUO24 (Core Authentication Service), DUO28 (Core Authentication Service), DUO4 (Core Authentication Service), DUO21 (Core Authentication Service), DUO20 (Core Authentication Service), DUO2 (Core Authentication Service), DUO65 (Core Authentication Service), DUO39 (Core Authentication Service), DUO47 (Core Authentication Service), DUO31 (Core Authentication Service), DUO46 (Core Authentication Service), DUO53 (Core Authentication Service), DUO48 (Core Authentication Service), DUO40 (Core Authentication Service), DUO27 (Core Authentication Service), DUO16 (Core Authentication Service), DUO26 (Core Authentication Service), DUO12 (Core Authentication Service), DUO29 (Core Authentication Service), DUO22 (Core Authentication Service), DUO55 (Core Authentication Service), DUO25 (Core Authentication Service), DUO32 (Core Authentication Service), DUO11 (Core Authentication Service), DUO37 (Core Authentication Service), DUO8 (Core Authentication Service), DUO38 (Core Authentication Service), DUO13 (Core Authentication Service), DUO17 (Core Authentication Service), DUO64 (Core Authentication Service), DUO3 (Core Authentication Service), DUO42 (Core Authentication Service), DUO14 (Core Authentication Service), DUO30 (Core Authentication Service), DUO50 (Core Authentication Service), DUO59 (Core Authentication Service), DUO57 (Core Authentication Service), DUO33 (Core Authentication Service), DUO56 (Core Authentication Service), DUO62 (Core Authentication Service), DUO34 (Core Authentication Service), DUO54 (Core Authentication Service), DUO52 (Core Authentication Service), DUO61 (Core Authentication Service), DUO6 (Admin Panel), and DUO35 (Core Authentication Service).