Multiple Deployments: Issues with Activity log being retrieved via Admin API
Incident Report for Duo
Resolved
Following a monitoring period, we have confirmed that the issue affecting Activity Log entries being retrieved via the Admin API has been resolved.

We will be posting a root-cause analysis (RCA) to this incident as soon as it is available.
Posted Dec 13, 2023 - 13:35 EST
Monitoring
We have finished rolling out a fix for this issue and are monitoring the results to ensure no recurrence of the issues.
Posted Dec 12, 2023 - 16:16 EST
Update
We are continuing to work on a fix for this issue.
Posted Dec 12, 2023 - 09:30 EST
Update
We are continuing to work on a fix for this issue.
Posted Dec 11, 2023 - 12:57 EST
Update
We are currently working to rollout a fix to this Admin API log retrieval issue. Similar logs to those unable to be pulled from the Admin API are still available through the Duo Admin Panel under Reports -> Administrator Actions or via the /admin/v1/logs/administrator endpoint in the Admin API.

Please check back here or subscribe for updates.
Posted Dec 08, 2023 - 13:45 EST
Identified
We have identified the root cause retrieving Activity log via Admin API. We will update with more information once know more.

Authentication logs, Administrator Logs and Telephony logs continue to be available and are not impacted.

Please check back here or subscribe for updates.
Posted Dec 07, 2023 - 20:33 EST
Investigating
We are currently investigating an issue that is affecting Activity Log entry being retrieved via the Admin API. We'll provide more updates as soon as we have more information. Authentication is unaffected at this time.
Posted Dec 07, 2023 - 18:45 EST
This incident affected: DUO6 (Admin Panel), DUO1 (Admin Panel), DUO2 (Admin Panel), DUO3 (Admin Panel), DUO4 (Admin Panel), DUO5 (Admin Panel), DUO7 (Admin Panel), DUO8 (Admin Panel), DUO47 (Admin Panel), DUO10 (Admin Panel), DUO11 (Admin Panel), DUO12 (Admin Panel), DUO13 (Admin Panel), DUO14 (Admin Panel), DUO15 (Admin Panel), DUO16 (Admin Panel), DUO17 (Admin Panel), DUO18 (Admin Panel), DUO19 (Admin Panel), DUO20 (Admin Panel), DUO21 (Admin Panel), DUO22 (Admin Panel), DUO23 (Admin Panel), DUO24 (Admin Panel), DUO25 (Admin Panel), DUO26 (Admin Panel), DUO27 (Admin Panel), DUO28 (Admin Panel), DUO29 (Admin Panel), DUO30 (Admin Panel), DUO31 (Admin Panel), DUO32 (Admin Panel), DUO33 (Admin Panel), DUO34 (Admin Panel), DUO36 (Admin Panel), DUO37 (Admin Panel), DUO38 (Admin Panel), DUO39 (Admin Panel), DUO40 (Admin Panel), DUO41 (Admin Panel), DUO42 (Admin Panel), DUO43 (Admin Panel), DUO44 (Admin Panel), DUO45 (Admin Panel), DUO46 (Admin Panel), DUO48 (Admin Panel), DUO9 (Admin Panel), DUO49 (Admin Panel), DUO50 (Admin Panel), DUO51 (Admin Panel), DUO52 (Admin Panel), DUO53 (Admin Panel), DUO54 (Admin Panel), DUO55 (Admin Panel), DUO56 (Admin Panel), DUO57 (Admin Panel), DUO58 (Admin Panel), DUO59 (Admin Panel), DUO60 (Admin Panel), DUO62 (Admin Panel), DUO63 (Admin Panel), DUO64 (Admin Panel), DUO65 (Admin Panel), DUO66 (Admin Panel), DUO67 (Admin Panel), DUO68 (Admin Panel), DUO69 (Admin Panel), DUO70 (Admin Panel), DUO71 (Admin Panel), DUO72 (Admin Panel), DUO73 (Admin Panel), and DUO35 (Admin Panel).