DUO64: Authentication failures for some users

Incident Report for Duo

Resolved

The issue causing authentication failures on DUO64 for some users has been fully resolved.
Posted Jun 02, 2025 - 15:51 EDT

Identified

We have identified the issue and have a fix rolling out now.
Posted Jun 02, 2025 - 14:20 EDT

Investigating

We are investigating authentication failures for some users on the DUO64 deployment, and will share more details as soon as possible.
Posted Jun 02, 2025 - 14:17 EDT
This incident affected: DUO64 (Core Authentication Service).