Issues Loading Admin Panel SSO Pages

Incident Report for Duo

Resolved

The issues loading SSO pages in the Admin Panel have been resolved.
Posted Jul 17, 2025 - 17:04 EDT

Monitoring

The loading issues affecting Admin Panel SSO Pages are subsiding as our deployment rollout completes. We are continuing to monitor the situation to ensure full resolution.
Posted Jul 17, 2025 - 16:56 EDT

Identified

We are currently investigating issues loading SSO pages in the Duo Admin Panel on some deployments and are working to correct the issue as soon as possible.

Please check back here or subscribe to updates for any changes.
Posted Jul 17, 2025 - 16:42 EDT
This incident affected: DUO1 (Admin Panel), DUO2 (Admin Panel), DUO15 (Admin Panel), DUO22 (Admin Panel), DUO41 (Admin Panel), DUO9 (Admin Panel), DUO60 (Admin Panel), DUO63 (Admin Panel), DUO64 (Admin Panel), DUO79 (Admin Panel), and DUO80 (Admin Panel).