Duo Support Portal page and help.duo.com - Certificate Expiration
Incident Report for Duo
Resolved
The issue causing certificate expiration messages when attempting to access the Duo Support Ticket Portal and help.duo.com pages has been fully resolved.
Posted Feb 06, 2024 - 13:47 EST
Monitoring
We are monitoring the fix deployed to ensure secure and correct access to the Duo Support Ticket Portal and help.duo.com pages.

Please make sure to check back here for further updates.
Posted Feb 06, 2024 - 13:38 EST
Identified
We have identified the issue causing certificate expiration warnings on our Duo Support Ticket Portal and help.duo.com pages and are working to deploy an updated certificate later today.

Please make sure to check back here for further updates.
Posted Feb 06, 2024 - 13:20 EST
Investigating
We are investigating reports of certificate expiration warnings on our Duo support portal web page and help.duo.com. We are actively investigating this issue and have placed a valid certificate to ensure connecting to these pages is secure.
Posted Feb 06, 2024 - 12:50 EST