[Multiple Deployments] - Issues with User Management in Admin Panel

Incident Report for Duo

Resolved

The issue affecting updates or changes made to users in the Admin Panel on selected deployments has been resolved.
Posted Aug 26, 2025 - 10:58 EDT

Monitoring

A fix has been deployed for the issue affecting updates or changes made to users in the Admin Panel on selected deployments. We are monitoring the results of the fix at this time.

Please check back here or subscribe to updates for any changes.
Posted Aug 26, 2025 - 10:48 EDT

Investigating

We are currently investigating an issue affecting updates or changes made to users in the Admin Panel on selected deployments.

Please check back here or subscribe to updates for any changes.
Posted Aug 26, 2025 - 10:43 EDT
This incident affected: DUO17 (Admin Panel, SSO), DUO39 (Admin Panel, SSO), DUO62 (Admin Panel, SSO), DUO65 (Admin Panel, SSO), DUO72 (Admin Panel, SSO), and DUO76 (Admin Panel, SSO).