All Deployments: User notification issues on Android Devices
Incident Report for Duo
Resolved
Our vendor has confirmed that a fix has been implemented and we have observed that Push notification delivery has returned to typical levels on all affected deployments.
Posted Oct 06, 2023 - 00:12 EDT
Monitoring
We have received an update from our vendor who have implemented a fix and affected devices will no longer see notification delivery issues as this fix rolls out over the next couple hours.

If you continuing to experience issues, you can open the Duo Mobile application to trigger the approve/deny authentication workflow as a temporary workaround.
Posted Oct 05, 2023 - 19:36 EDT
Update
We are continuing to work with our vendor to determine how to best mitigate the issue.
Posted Oct 05, 2023 - 16:18 EDT
Update
At this time our engineering team is still investigating the root cause for the failed notification deliveries on Android devices and verifying which deployments are impacted.

The issue has been partially identified at this time, and we are working with our vendor to determine how to best mitigate the issue. We are currently awaiting more details in order to begin working on a fix.

If you are experiencing issues, you can open the Duo Mobile application to trigger the approve/deny authentication workflow as a temporary workaround.
Posted Oct 05, 2023 - 15:27 EDT
Update
At this time our engineering team is still investigating the root cause for the failed notification deliveries on Android devices and verifying which deployments are impacted.

We are currently conversing with our third party vendors. The outcome of this conversation and troubleshooting effort will produce an action plan for quickly resolving our issue. We’ll update again in 30 minutes or sooner if there is additional information to share.

If you are experiencing issues, you can open the Duo Mobile application to trigger the approve/deny authentication workflow as a temporary workaround.
Posted Oct 05, 2023 - 14:40 EDT
Update
At this time our Engineering team is still investigating the root cause for the failed notification deliveries on Android and looking at our deployments to see if there is an issue. If you are experiencing issues, you can open the Duo Mobile application to trigger the approve/deny authentication workflow as a temporary workaround.

Please check back here or subscribe to updates for any changes.
Posted Oct 05, 2023 - 13:09 EDT
Update
We are currently investigating the root cause for the failed notification deliveries on Android and looking at our deployments to see if there is an issue. If you are experiencing issues, you can open the Duo Mobile application to trigger the approve/deny authentication workflow as a temporary workaround.

Please check back here or subscribe to updates for any changes.
Posted Oct 05, 2023 - 12:20 EDT
Update
We are still investigating the root cause of push notifications not being delivering for users. During our investigation, we found the issue isolated to Android devices. If you are experiencing issues, you can open the Duo Mobile application to trigger the approve/deny authentication workflow as a temporary workaround.
Posted Oct 05, 2023 - 11:23 EDT
Update
If you are experiencing trouble receiving pushes, please open Duo Mobile and you should be able to proceed with the authentication.
Posted Oct 05, 2023 - 10:16 EDT
Investigating
We are currently investigating an issue with users not getting Duo Push notification when completing MFA. This is affecting iOS and Android devices.

Please check back here or subscribe to updates for any changes.
Posted Oct 05, 2023 - 10:08 EDT
This incident affected: DUO1 (Push Delivery), DUO2 (Push Delivery), DUO3 (Push Delivery), DUO4 (Push Delivery), DUO5 (Push Delivery), DUO6 (Push Delivery), DUO7 (Push Delivery), DUO8 (Push Delivery), DUO47 (Push Delivery), DUO10 (Push Delivery), DUO11 (Push Delivery), DUO12 (Push Delivery), DUO13 (Push Delivery), DUO14 (Push Delivery), DUO15 (Push Delivery), DUO16 (Push Delivery), DUO17 (Push Delivery), DUO18 (Push Delivery), DUO19 (Push Delivery), DUO20 (Push Delivery), DUO21 (Push Delivery), DUO22 (Push Delivery), DUO23 (Push Delivery), DUO24 (Push Delivery), DUO25 (Push Delivery), DUO26 (Push Delivery), DUO27 (Push Delivery), DUO28 (Push Delivery), DUO29 (Push Delivery), DUO30 (Push Delivery), DUO31 (Push Delivery), DUO32 (Push Delivery), DUO33 (Push Delivery), DUO34 (Push Delivery), DUO36 (Push Delivery), DUO37 (Push Delivery), DUO38 (Push Delivery), DUO39 (Push Delivery), DUO40 (Push Delivery), DUO41 (Push Delivery), DUO42 (Push Delivery), DUO43 (Push Delivery), DUO44 (Push Delivery), DUO45 (Push Delivery), DUO46 (Push Delivery), DUO48 (Push Delivery), DUO9 (Push Delivery), DUO49 (Push Delivery), DUO50 (Push Delivery), DUO51 (Push Delivery), DUO52 (Push Delivery), DUO53 (Push Delivery), DUO54 (Push Delivery), DUO55 (Push Delivery), DUO56 (Push Delivery), DUO57 (Push Delivery), DUO58 (Push Delivery), DUO59 (Push Delivery), DUO60 (Push Delivery), DUO61 (Push Delivery), DUO62 (Push Delivery), DUO63 (Push Delivery), DUO64 (Push Delivery), DUO65 (Push Delivery), DUO66 (Push Delivery), DUO67 (Push Delivery), DUO68 (Push Delivery), DUO69 (Push Delivery), DUO70 (Push Delivery), DUO71 (Push Delivery), DUO72 (Push Delivery), DUO73 (Push Delivery), and DUO35 (Push Delivery).