Phone Call Authentication Delivery Failures
Incident Report for Duo
Resolved
The issue regarding Phone Call Authentication issues on our deployments is fully resolved and all services are now fully functional.
Posted Dec 15, 2023 - 11:49 EST
Monitoring
Phone call authentication failures have subsided after a workaround was applied on Duo's end. We are actively monitoring telephony authentications for any recurrence.
Posted Dec 15, 2023 - 11:32 EST
Investigating
We are currently investigating an issue impacting phone call authentication delivery from one of our providers across all regions. A failover strategy to an alternate provider is currently in work.
Posted Dec 15, 2023 - 10:28 EST