All Deployments: Unable to update payment information in the Duo Admin Panel
Incident Report for Duo
Postmortem

Summary

From 12:09 p.m EDT September 1, 2020 to 11:00 p.m. EDT September 9, 2020, some Duo customers were unable to update their payment information in the Duo Admin Panel. This issue has been identified and fully resolved.

Details

At 5:59 a.m. EDT on September 9, 2020, Duo observed an increased number of support escalations due to customers not being able to submit or update payment information on the Admin Panel Payment Info Page.

Upon further investigation, two issues were identified with a recent release that was deployed on September 1, 2020. The first issue was that payment updates failed due to invalid ZIP code validations and were not being reported back to customers. The second issue was that all payment updates for non-U.S. customers were being declined as invalid updates.

The release has been patched with fixes for these issues and the customer issues have been resolved. Moving forward, Duo will investigate additional options to increase testing robustness for different geographic locations.

Posted Sep 10, 2020 - 12:20 EDT

Resolved
The change has been implemented and the issue with entering or updating payment information has been resolved.

We will be posting a Root-Cause Analysis (RCA) to this incident as soon as it is available
Posted Sep 10, 2020 - 09:06 EDT
Monitoring
Our engineering team successfully deployed a change to resolve the issue with updating payment information in the Duo Admin Panel on all of our deployments. Duo credit card customers are now able to enter or update their credit card details and we are continuing to monitor this.
Posted Sep 09, 2020 - 23:05 EDT
Update
We are continuing to investigate and believe that this issue is only affecting some non-US customers located in countries that have VAT requirements.
We will continue to provide updates as we acquire additional information.
Posted Sep 09, 2020 - 11:01 EDT
Identified
We are aware of and tracking an ongoing issue with our payment processor, and will provide further updates on the progress of correcting the issue.

Please check back here or subscribe to updates for any changes.
Posted Sep 09, 2020 - 07:22 EDT
Investigating
We are currently investigating an issue with updating payment information in the Duo Admin Panel on all of our deployments. Duo pre-paid credit card customers are unable to enter or update their credit card details.
Please check back here or subscribe to updates for any changes
Posted Sep 09, 2020 - 06:57 EDT
This incident affected: DUO6 (Admin Panel), DUO52 (Admin Panel), DUO65 (Admin Panel), DUO36 (Admin Panel), DUO59 (Admin Panel), DUO50 (Admin Panel), DUO49 (Admin Panel), DUO42 (Admin Panel), DUO61 (Admin Panel), DUO58 (Admin Panel), DUO9 (Admin Panel), DUO53 (Admin Panel), DUO46 (Admin Panel), DUO43 (Admin Panel), DUO48 (Admin Panel), DUO41 (Admin Panel), DUO37 (Admin Panel), DUO44 (Admin Panel), DUO40 (Admin Panel), DUO28 (Admin Panel), DUO23 (Admin Panel), DUO26 (Admin Panel), DUO20 (Admin Panel), DUO15 (Admin Panel), DUO13 (Admin Panel), DUO11 (Admin Panel), DUO12 (Admin Panel), DUO30 (Admin Panel), DUO7 (Admin Panel), DUO5 (Admin Panel), DUO47 (Admin Panel), DUO31 (Admin Panel), DUO10 (Admin Panel), DUO2 (Admin Panel), DUO19 (Admin Panel), DUO29 (Admin Panel), DUO25 (Admin Panel), DUO4 (Admin Panel), DUO27 (Admin Panel), DUO14 (Admin Panel), DUO57 (Admin Panel), DUO51 (Admin Panel), DUO34 (Admin Panel), DUO16 (Admin Panel), DUO1 (Admin Panel), DUO32 (Admin Panel), DUO21 (Admin Panel), DUO33 (Admin Panel), DUO38 (Admin Panel), DUO64 (Admin Panel), DUO55 (Admin Panel), DUO8 (Admin Panel), DUO54 (Admin Panel), DUO62 (Admin Panel), DUO60 (Admin Panel), DUO63 (Admin Panel), DUO56 (Admin Panel), DUO17 (Admin Panel), DUO39 (Admin Panel), DUO22 (Admin Panel), DUO45 (Admin Panel), DUO24 (Admin Panel), DUO18 (Admin Panel), DUO3 (Admin Panel), and DUO35 (Admin Panel).