EMEA Issue with Delivery of Phone Call Authentications
Incident Report for Duo
Resolved
We can confirm that the phone authentication delivery issue has been remediated within the United Kingdom.

The issue will continue to be monitored to ensure it is completely resolved.

An RCA will be posted detailing the issue once available.

Please check back here or subscribe for further updates.
Posted Nov 12, 2019 - 12:01 EST
Monitoring
A fix for phone delivery issues for UK phone numbers has been implemented.

We will continue to monitor the issue to ensure it is completely resolved.
Posted Nov 12, 2019 - 08:14 EST
Investigating
We have received some reports of phone call authentication failures specific to the UK region and are currently working to determine the cause of this issue.

Some customers have remediated this issue by changing the outbound Caller-ID configured in the Settings within the Duo Admin Panel.

Please check back here or subscribe to updates for any changes.
Posted Nov 12, 2019 - 07:45 EST
This incident affected: DUO47 (Phone Call Delivery), DUO57 (Phone Call Delivery), and DUO3 (Phone Call Delivery).